State of Moonbase

lunar1I am expecting a weekend moonbase update. I am talking about Lunar Linux here, and not the real moon! Linux-2.6.29.2 was released on April 27th, and it’s already in moonbase git, and so is firefox 3.0.10. Just those two will take a while to build. Firefox on my EEE, for instance took a solid four hours or so to be built. But since the last two firefox updates, the option to build it with Profile Guided Optimization is activated, so no wonder why it takes longer to compile than the usual. But PGO sure made my firefox real fast.

Moonbase Update – April24, 2009

Lunar Linux’s package repository, moonbase was updated yesterday with brand new source codes of many packages. The following are the details of the updates. I updated three of my desktops and an EEE last night, and in another half an hour, will start an update on my laptop, and go to bed. It will take a while, since firefox has to be updated to 3.0.9 as you can see in the available updates.

Removed modules: (11)
Wine-cvs
burnmp3
cube
cube-bin
dri
equate-cvs
gaupol
gsf-sharp-svn
lvm
prism54
scribus-devel

New versions: (84)
CriticalMass            :           1.0.0 ->           1.0.2
NVIDIA                  :          180.44 ->          180.53
SDL_gfx                 :          2.0.18 ->          2.0.19
airconfig-svn           :          svn-15 ->          svn-16
ardour                  :             2.7 ->             2.8
bluez                   :            4.34 ->            4.36
bridge-utils            :             1.1 ->             1.4
busybox                 :          1.13.3 ->          1.13.4
busybox_static          :          1.13.3 ->          1.13.4
dri2proto               :          1.99.3 ->             2.0
e17-svn                 :      svn-200915 ->      svn-200916
e_dbus-svn              :      svn-200915 ->      svn-200916
e_modules-svn           :      svn-200915 ->      svn-200916
e_utils-svn             :      svn-200915 ->      svn-200916
eclair-svn              :      svn-200915 ->      svn-200916
ecore-svn               :      svn-200915 ->      svn-200916
edje-svn                :      svn-200915 ->      svn-200916
eet-svn                 :      svn-200915 ->      svn-200916
efreet-svn              :      svn-200915 ->      svn-200916
eina-svn                :      svn-200915 ->      svn-200916
elicit-svn              :      svn-200915 ->      svn-200916
embryo-svn              :      svn-200915 ->      svn-200916
emotion-svn             :      svn-200915 ->      svn-200916
emprint-svn             :      svn-200915 ->      svn-200916
engrave-svn             :      svn-200915 ->      svn-200916
entice-svn              :      svn-200915 ->      svn-200916
epsilon-svn             :      svn-200915 ->      svn-200916
esmart-svn              :      svn-200915 ->      svn-200916
etk-svn                 :      svn-200915 ->      svn-200916
evas-svn                :      svn-200915 ->      svn-200916
ewl-svn                 :      svn-200915 ->      svn-200916
examine-svn             :      svn-200915 ->      svn-200916
exhibit-svn             :      svn-200915 ->      svn-200916
exml-svn                :      svn-200915 ->      svn-200916
faac                    :            1.26 ->            1.28
fasm                    :         1.67.26 ->         1.67.38
fglrx                   :             9.3 ->             9.4
findutils               :           4.4.0 ->           4.4.1
firefox                 :           3.0.8 ->           3.0.9
fluidsynth              :           1.0.8 ->           1.0.9
freedroidrpg            :            0.12 ->          0.12.1
gegl                    :          0.0.20 ->          0.0.22
ghal-svn                :          svn-15 ->          svn-16
git                     :         1.6.2.3 ->         1.6.2.4
gitosis-git             :          git-15 ->          git-16
glade3                  :           3.6.2 ->           3.6.3
glib-2                  :            20.0 ->            20.1
gnucash                 :           2.2.8 ->           2.2.9
hdparm                  :            9.14 ->            9.15
imlib2-svn              :      svn-200915 ->      svn-200916
imlib2_loaders-svn      :      svn-200915 ->      svn-200916
k9copy2                 :    2.3.0-Source ->    2.3.1-Source
leafnode                :          1.11.6 ->          1.11.7
libdbi                  :           0.8.2 ->           0.8.3
libevent                :    1.4.9-stable ->   1.4.10-stable
libisofs                :          0.6.16 ->          0.6.18
liboil                  :          0.3.15 ->          0.3.16
linphone                :           2.1.1 ->           3.1.1
mp3blaster              :           3.2.3 ->           3.2.5
netatalk                :           2.0.1 ->           2.0.3
numpy                   :           1.2.1 ->           1.3.0
ortp                    :          0.13.1 ->          0.15.0
poppler                 :          0.10.5 ->          0.10.6
qmpdclient              :           1.0.9 ->           1.1.0
qt4                     :           4.5.0 ->           4.5.1
ristretto               :          0.0.16 ->          0.0.21
rpm                     :           5.1.8 ->           5.1.9
rsyslog                 :          3.20.5 ->          3.22.0
schroedinger            :           1.0.5 ->           1.0.6
scim                    :           1.4.8 ->           1.4.9
scim-anthy              :           1.2.0 ->           1.2.7
semantik                :           0.5.8 ->           0.7.1
slim                    :           1.3.0 ->           1.3.1
star                    :           1.4.3 ->             1.5
sudo                    :           1.7.0 ->           1.7.1
testdisk                :            6.10 ->            6.11
vala                    :           0.7.0 ->           0.7.1
webkitkde               :          svn-15 ->          svn-16
weechat                 :         0.2.6.1 ->         0.2.6.2
xarchiver               :           0.4.6 ->           0.5.2
xf86-input-joystick     :           1.4.0 ->           1.4.1
xfce4-taskmanager       :           0.3.2 ->           0.4.1
xfce4-wavelan-plugin    :           0.5.3 ->           0.5.5
xulrunner               :         1.9.0.6 ->         1.9.0.7

Moved modules:
qmpdclient              :           zbeta ->        qt4-apps
semantik                :           zbeta ->       doc-tools

Current Moonbase Status – Lunar Linux

The moonbase, the main repository of Lunar Linux has been updated today, and new versions of the packages have been added. Besides some modules were removed or moved. The details are as follows:

New modules: (15)
ClientForm-0.2.10: a Python module for handling HTML forms on the client side
asterisk-1.6.0.9: open source PBX and telephony engine
avogadro-0.9.3: an advanced molecular editor
elektra-0.7.0: hierarchical configuration store
gigolo-0.3.0: frontend to manage connections to remote filesystems
gtkhtml-3.26.1.1: html rendering/editing library.
icc_examin-0.46: a colour management utility
iksemel-1.3: an XML parser library for jabber
krusader4-2.0.0: KDE Twin-Panel filemanager
monodevelop-vala-2.0: vala template for monodevelop
murrine-0.90.0: Cairo-based GTK+-2 theme engine
portaudio-v19_20071207: audio I/O library
spandsp-0.0.6: DSP functions for telephony
taglib-extras-0.1.2: taglib-extras handles proprietary file formats
txt2tags-2.5: a document generator

Removed modules: (4)
Compress-Raw-Zlib
Module-Build
Murrine-Engine
gtkhtml3

New versions: (215)
CherryPy                :           3.1.0 ->           3.1.2
GConf                   :          2.24.0 ->          2.26.0
ORBit2                  :         2.14.16 ->         2.14.17
Python                  :           2.6.1 ->           2.6.2
airconfig-svn           :          svn-14 ->          svn-15
at-spi                  :          1.24.1 ->          1.26.0
atk                     :          1.24.0 ->          1.26.0
bogofilter              :           1.1.7 ->           1.2.0
brasero                 :           0.9.1 ->          2.26.1
bug-buddy               :          2.24.2 ->          2.26.0
busybox                 :          1.13.2 ->          1.13.3
busybox_static          :          1.13.2 ->          1.13.3
calibre                 :           0.5.3 ->           0.5.6
cheese                  :          2.24.3 ->          2.26.0
cups                    :           1.3.9 ->          1.3.10
dbmail                  :           2.2.8 ->          2.2.11
deskbar-applet          :          2.24.3 ->          2.26.0
dovecot                 :          1.1.13 ->          1.1.14
e17-svn                 :      svn-200914 ->      svn-200915
e_dbus-svn              :      svn-200914 ->      svn-200915
e_modules-svn           :      svn-200914 ->      svn-200915
e_utils-svn             :      svn-200914 ->      svn-200915
eclair-svn              :      svn-200914 ->      svn-200915
ecore-svn               :      svn-200914 ->      svn-200915
edje-svn                :      svn-200914 ->      svn-200915
eel                     :          2.24.1 ->          2.26.0
eet-svn                 :      svn-200914 ->      svn-200915
efreet-svn              :      svn-200914 ->      svn-200915
eina-svn                :      svn-200914 ->      svn-200915
ekiga                   :           3.0.2 ->           3.2.0
elicit-svn              :      svn-200914 ->      svn-200915
embryo-svn              :      svn-200914 ->      svn-200915
emotion-svn             :      svn-200914 ->      svn-200915
empathy                 :          2.25.4 ->          2.26.1
emprint-svn             :      svn-200914 ->      svn-200915
engrave-svn             :      svn-200914 ->      svn-200915
entice-svn              :      svn-200914 ->      svn-200915
eog                     :        2.24.3.1 ->          2.26.1
epiphany                :          2.24.3 ->          2.27.0
epiphany-extensions     :          2.24.3 ->          2.26.1
epsilon-svn             :      svn-200914 ->      svn-200915
esmart-svn              :      svn-200914 ->      svn-200915
etk-svn                 :      svn-200914 ->      svn-200915
evas-svn                :      svn-200914 ->      svn-200915
evince                  :          2.24.2 ->          2.26.1
evolution               :          2.24.4 ->        2.26.1.1
evolution-data-server   :        2.24.4.1 ->        2.26.1.1
evolution-exchange      :          2.24.4 ->          2.26.1
evolution-webcal        :          2.24.0 ->          2.26.0
ewl-svn                 :      svn-200914 ->      svn-200915
examine-svn             :      svn-200914 ->      svn-200915
exhibit-svn             :      svn-200914 ->      svn-200915
exml-svn                :      svn-200914 ->      svn-200915
file-roller             :          2.24.3 ->          2.26.1
gcalctool               :          5.24.3 ->          5.26.1
gconf-editor            :          2.24.1 ->          2.26.0
gdl                     :          2.24.0 ->          2.26.0
gdm                     :          2.24.1 ->          2.26.1
gedit                   :          2.24.3 ->          2.26.1
gedit-plugins           :          2.22.5 ->          2.26.1
ghal-svn                :          svn-14 ->          svn-15
git                     :         1.6.2.2 ->         1.6.2.3
gitosis-git             :          git-14 ->          git-15
glade3                  :           3.4.5 ->           3.6.2
glib-2                  :            18.4 ->            20.0
glibmm                  :          2.18.1 ->          2.20.0
gmime                   :           2.4.3 ->           2.4.6
gnome-applets           :        2.24.3.1 ->          2.26.1
gnome-backgrounds       :          2.24.0 ->          2.24.1
gnome-bluetooth         :          0.11.0 ->          0.12.0
gnome-common            :          2.24.0 ->          2.26.0
gnome-control-center    :          2.24.0 ->          2.26.0
gnome-desktop           :          2.24.3 ->          2.26.1
gnome-doc-utils         :          0.15.1 ->          0.16.1
gnome-games             :          2.24.3 ->          2.26.1
gnome-games-extra-data  :          2.24.0 ->          2.26.0
gnome-icon-theme        :          2.24.0 ->          2.26.0
gnome-keyring           :          2.24.1 ->          2.26.1
gnome-media             :        2.24.0.1 ->          2.26.0
gnome-menus             :          2.24.2 ->          2.26.1
gnome-netstatus         :          2.12.2 ->          2.26.0
gnome-nettool           :          2.22.1 ->          2.26.1
gnome-panel             :          2.24.3 ->          2.26.1
gnome-power-manager     :          2.24.4 ->          2.26.0
gnome-python            :          2.22.3 ->          2.26.1
gnome-python-desktop    :          2.24.1 ->          2.26.0
gnome-python-extras     :          2.19.1 ->          2.25.3
gnome-screensaver       :          2.24.1 ->          2.26.1
gnome-session           :          2.24.3 ->          2.26.1
gnome-settings-daemon   :          2.24.1 ->          2.26.1
gnome-system-monitor    :          2.24.4 ->          2.26.1
gnome-system-tools      :          2.22.1 ->          2.22.2
gnome-terminal          :          2.24.3 ->          2.26.1
gnome-themes            :          2.24.3 ->          2.26.1
gnome-user-docs         :          2.24.2 ->          2.26.1
gnome-utils             :          2.24.1 ->          2.26.0
gnome-vfs               :          2.24.0 ->          2.24.1
gnome-vfsmm             :          2.24.0 ->          2.26.0
gnome2                  :          2.24.x ->          2.26.x
gok                     :          2.24.0 ->          2.26.0
gtk+-2                  :            14.7 ->            16.1
gtkmm                   :          2.14.3 ->          2.16.0
gtksourceview           :           2.4.2 ->           2.6.1
gucharmap               :          2.24.3 ->          2.26.1
guidance-power-manager  :           4.2.0 ->           4.2.2
gvfs                    :           1.0.3 ->           1.2.2
imap                    :           2004g ->           2007e
imlib2                  :           1.4.1 ->           1.4.2
imlib2-svn              :      svn-200914 ->      svn-200915
imlib2_loaders-svn      :      svn-200914 ->      svn-200915
intltool                :          0.40.5 ->          0.40.6
kcoloredit              :           4.2.0 ->           4.2.2
kdenlive4               :         0.7.2.1 ->           0.7.3
kfax                    :           4.2.0 ->           4.2.2
kgrab                   :           4.2.0 ->           4.2.2
kgraphviewer            :           4.1.3 ->           4.2.2
kiconedit               :           4.2.0 ->           4.2.2
kio_gopher              :           4.2.0 ->           4.2.2
kmldonkey4              :           4.2.0 ->           4.2.2
konq-plugins            :           4.2.0 ->           4.2.2
kopete-cryptography     :           4.2.0 ->           4.2.2
kpovmodeler             :           4.2.0 ->           4.2.2
less                    :             418 ->             429
libIDL                  :          0.8.12 ->          0.8.13
libX11                  :             1.2 ->           1.2.1
libbonobo               :          2.24.0 ->          2.24.1
libbonoboui             :          2.24.0 ->          2.24.1
libbtctl                :          0.11.0 ->          0.11.1
libcanberra             :             0.9 ->            0.11
libdrm                  :           2.4.7 ->           2.4.9
libglade                :           2.6.3 ->           2.6.4
libgnome                :          2.24.1 ->          2.26.0
libgnomecanvas          :        2.20.1.1 ->          2.26.0
libgnomecanvasmm        :          2.23.1 ->          2.26.0
libgnomekbd             :          2.24.0 ->          2.26.0
libgnomemm              :          2.24.0 ->          2.26.0
libgnomeprint           :          2.18.5 ->          2.18.6
libgnomeprintui         :          2.18.3 ->          2.18.4
libgnomeui              :          2.24.0 ->          2.24.1
libgnomeuimm            :          2.24.0 ->          2.26.0
libgtop                 :          2.24.4 ->          2.26.1
libgweather             :          2.24.3 ->          2.26.1
librsvg                 :          2.22.3 ->          2.26.0
libsoup                 :         2.25.91 ->          2.26.1
libtasn1                :          0.3.10 ->             1.4
libwnck                 :          2.24.2 ->          2.26.1
libxklavier             :             3.8 ->             3.9
libxml++                :          2.24.2 ->          2.26.0
man-pages               :            3.20 ->            3.21
memcached               :          1.1.12 ->           1.2.8
metacity                :          2.24.0 ->          2.26.0
midori                  :           0.1.4 ->           0.1.5
mkvtoolnix              :           2.6.0 ->           2.7.0
mlt                     :           0.3.6 ->           0.3.8
mlt++                   :           0.3.6 ->           0.3.8
mysql                   :          5.0.75 ->          5.0.77
nautilus                :          2.24.2 ->          2.26.2
nautilus-cd-burner      :          2.24.0 ->          2.25.3
opal                    :           3.4.4 ->           3.6.1
openldap                :          2.4.15 ->          2.4.16
orca                    :          2.24.3 ->          2.26.1
oyranos                 :           0.1.7 ->           0.1.9
pango                   :          1.22.4 ->          1.24.1
pangomm                 :          2.14.1 ->          2.24.0
pcre                    :             7.8 ->             7.9
phpMyAdmin              :         3.1.3.1 ->         3.1.3.2
pixman                  :          0.14.0 ->          0.15.2
popt                    :            1.14 ->            1.15
ptlib                   :           2.4.4 ->           2.6.1
pulseaudio              :          0.9.14 ->          0.9.15
pygobject               :          2.16.0 ->          2.16.1
pygtksourceview         :           2.4.0 ->           2.6.0
rhythmbox               :          0.11.6 ->          0.12.0
rpm                     :           5.1.7 ->           5.1.8
rsyslog                 :          3.20.4 ->          3.20.5
scribus                 :        1.3.3.12 ->        1.3.3.13
seahorse                :          2.24.1 ->          2.26.1
seahorse-plugins        :          2.24.1 ->          2.26.1
seamonkey               :          1.1.15 ->          1.1.16
skanlite                :           4.2.0 ->           4.2.2
sound-juicer            :          2.24.0 ->          2.26.1
sqlite                  :          3.6.12 ->          3.6.13
squid                   :    3.0.STABLE13 ->    3.0.STABLE14
stella                  :           2.7.5 ->           2.7.6
stunnel                 :            4.26 ->            4.27
subversion              :           1.6.0 ->           1.6.1
swfdec-gnome            :          2.24.0 ->          2.26.0
syslinux                :            3.73 ->            3.75
system-tools-backends   :           2.6.0 ->           2.6.1
tcl                     :           8.5.6 ->           8.5.7
telepathy-gabble        :          0.7.18 ->          0.7.23
telepathy-glib          :          0.7.23 ->          0.7.27
telepathy-idle          :           0.1.2 ->           0.1.3
telepathy-python        :          0.15.6 ->          0.15.7
telepathy-salut         :           0.3.7 ->           0.3.8
tig                     :          0.12.1 ->          0.14.1
timezone-data           :           2009e ->           2009f
tk                      :           8.5.6 ->           8.5.7
totem                   :          2.24.4 ->          2.26.1
totem-pl-parser         :          2.24.4 ->          2.26.1
transmission            :            1.51 ->            1.52
vinagre                 :          2.24.2 ->          2.26.1
vino                    :          2.24.1 ->          2.26.1
vte                     :          0.19.4 ->          0.20.1
webkit                  :           1.1.3 ->           1.1.5
webkitkde               :          svn-14 ->          svn-15
wesnoth                 :           1.4.7 ->           1.6.1
wine                    :          1.1.18 ->          1.1.19
xchat-gnome             :            0.18 ->          0.26.1
xf86-video-ati          :          6.12.1 ->          6.12.2
xinput                  :           1.4.0 ->           1.4.1
xorg-server             :           1.6.0 ->           1.6.1
yasm                    :           0.7.2 ->           0.8.0
yelp                    :          2.24.0 ->          2.26.0
zenity                  :          2.24.1 ->          2.26.0

Moved modules:
qshaderedit             :           zbeta ->        qt4-apps